#rubyonrails - Sat 12 May 2007 between 00:01 and 00:48

NY Lost Funds



longinttextmate or aptana?
cartertextmate
hayz_osxnever used aptana. love textmate.
argoehas anyone used the mongrel upload progress plugin on OS X?
I haven't got the progress part to work and I'm wondering if it's an OS X thing or something I'm just missing
lonnyFYI, to anyone who was following my problem earlier: The simple fact is, either Rails or MySQL simply did not like "line_items" for a table name. I changed it, and everything works fine. And that is very, very bad.
fowlduckis line_items reserved in mysql?
lonnyfowlduck: It isn't in the list.
fowlduckweird
lonnyYeah, tell me. I spent half a day trying to resolve this.
fowlduckdoes active record interpret underscores as join tables?
solution: rbatis ;)
lonnyfowlduck: It shouldn't. I mean, you specify that manually.
fowlduck: I should be able to call my table this_is_my_table if I want.
fowlduckthis isn't configuration over convention here, there are standards to follow
zachinglisHow do I set default_url_options[:host] for
fowlducki'd check on that
lonny(Or aqctually, these_are_my_records).
fowlduck: If activerecord interprets underscores as join tables, this is absolutely the first time I have heard of that. Anybody else on this?
fowlducklonny: i'm really not sure, but i'd bet its a convention for something that you weren't doing
lonnyfowlduck: Perhaps. But again: if so, this is absolutely the first time I have been exposed to any such.
argoei don't think so. underscores are used in table names all the time. any time you have a model with a compound name LineItem for example, you'll get line_items for the table
fowlduckhmm
was your model called LineItem?
lonnyargoe: I wonder if "items" conflicted somehow.
zachinglisfowlduck: Yes, underscore tables are for HABTM, but you must set it in the model too.
argoei don't think so
zachinglisBut make sure you have the right pluralisation
lonnyMy model was line_item.rb (class LineItem within the file)
Table name was line_items
argoedid you hardcode the table name in your model? it should have figured that out all on its own.
lonnyargoe: No, I did not do it manually.
argoewhat was the actual error message?
lonnyargoe: I have been over that too many times already. Well, once more but this is the last: HY000Can't create table <mysql tablename.frm here> errno: 150
argoethe depot tutorial in the agile book uses line_items so i thinnk we can pretty much assume it's not a bad name
lonnyargoe: During migrate.
argoei went through the tutorial and never had a problem with that table name
hrm
lonnyargoe: All I can say is, when I changed the table to my_items and my_item.rb, everything worked fine.
argoeand that was during the migration for line_items?

Page: 2 9 16 23 30 37 44 51 58 65 

IrcArchive

NY Lost Funds