#gentoo - Thu 5 Apr 2007 between 01:32 and 01:51

NY Lost Funds



jmbsvicettokexman: The tarball has /dev/zero and /dev/console
igli/dev/null is needed as well
HedgeMagejmbsvicetto: because if I use that grub console at boot to put in the needed info, it starts to boot then kernel panics trying to mount / (I have reiser support in the kernel so I don't get what's up)
jmbsvicettoHedgeMage: Those seem to be 2 different issues
HedgeMage: Does it stop before the grub menu?
HedgeMagejmbsvicetto: also, if I boot to cd and chroot in and try to use grub to configure (instead of grub-install) grub segfaults when I put in the kernel line but doesn't if I omit the root=/dev/sda3 at the end
jmbsvicetto: I never get to the grub menu, correct, just a grub prompt
kexmanjmbsvicetto, im talking about other chrootings
i have a system in a chroot
and i emerge things in it
doesnt it need a full /dev ?
Draconx|Laptopkexman, the stage tarballs /have/ a full dev for most systems
jmbsvicettokexman: You can try it. If it complains, you know what you have to do ;)
kexmanjmbsvicetto, i never wayted for that :)
jmbsvicettoHedgeMage: Make sure that you have the boot symlink in the /boot partition / dir
TTTDraconx|Laptop: this stage3 had everything in /dev, hope it's enough for this macbook
jmbsvicettoHedgeMage: Look at the output of fdisk -l - is /dev/sda3 marked as type 83 ?
HedgeMageyes
TTTi learned something so it's ok
jmbsvicettoHedgeMage: Look at the contents of /boot/grub - do you have the reiserfs_stage1_5 file?
HedgeMageyes but the boot symlink was broken... let me see if that did it
jmbsvicetto: I shouldn't have to re-run grub-install for fixing the boot link to take effect, right?
jmbsvicettoyes, you shouldn't need to
HedgeMage: However, given that you got that error when running grub, instead of grub-install, try again to install with grub
kantlivelonghow can i ensure everything uses alsa by default? even with no oss in kernel
HedgeMagejmbsvicetto: will do, one sec, have to reboot to cd and do all the chroot stuff
t35t0rwould you use it if it didn't have a = advanced?
i use elsa = elite linux sound architecture
it is better than alsa
hydrogenI use directsound via wine
because i'mcoollikethat
summatusmentisgentoo is a pretty straightforward install right? how familiar should I be with USE flags and so forth, first time through?
jmbsvicettosummatusmentis: Take a good look at http://www.gentoo.org/doc/en/handbook
t35t0rput all use flags in /etc/make.conf
iglisummatusmentis: don't worry too much
t35t0rdon't bother with /etc/portage/package.use you'll mess yourself up
iglieveryone thinks like that
summatusmentisjmbsvicetto: ok, is that it for the first time through?
igli: well, I'm not too worried about it, just.... well, 'go time' reservations about killing me debian system
jmbsvicettosummatusmentis: Yes

Page: 4 11 18 25 32 39 46 53 60 67 74 81 88 95 102 109 116 123 130 137 144 151 158 165 172 179 

IrcArchive

NY Lost Funds