#gentoo - Thu 5 Apr 2007 between 12:10 and 12:22

NY Lost Funds



YippMNcan anyone give me an idea what this error means? QA Notice: USE Flag 'arts' not in IUSE for games-sports/kbilliards-0.8.7b
Alias|If emerge told me to 'Please reemerge =x11-libe/qt-3* with USE="opengl".' what is the correct set of commands? I have tried 'USE="opengl"' and then 'reemerge =x11-libs/qt3*' and then 'reemerge kde' and it came back with the same error.
YippMNi did enable the arts use flag in make.conf hmmm
not sure i know what IUSE is?
gent00YippMN: for what do u need arts? it's almost deprecated...
YippMNgent00, well for the game it shows in the error , and yes i know arts is almost gone , and i use alsa
mark_alecAlias|: echo "x11-libs/qt opengl" >> /etc/portage/package.use && emerge --oneshot =qt-3* && emerge kde-meta (or whichever package you were trying to emerge)
YippMNgent00, but it says it needs arts use in IUSE , whats IUSE :)
Fenix|workAlias|, USE="opengl" emerge =x11-libs/qt-3.3.6-r4 <--- that's stable
YippMNgent00, i imagine that kbilliards wants to still use arts for its sound
Fenix|workAlias|, or you could echo "x11-libs/qt opengl" >> /etc/portage/package.use then emerge =x11-libs/qt-3.3.6-r4
hkBstYippMN: it is an ebuild variable. It declares what use flags are available for an ebuild
terlmannI want ppracer .5 , why is it stuck at .3 ?
hkBstYippMN: so kbilliards uses the use flag arts without declaring that it does so. Some eclass is prolly to blame...
YippMNhkBst, so is it possible to add arts use flag to IUSE then
hkBstYippMN: in principle yes
gOLdenHaWK3Dhi all
Fenix|workterlmann, my games-arcade/ppracer doesn't have a .5 ... just 0.3.1
Amon-sanif i set RC_BOOTLOG="yes" how can i access the log? anyone please?
YippMNhkBst, the other thing it says is that when i set arts use in make.conf and tried to recompile , it says i should recompile kdelibs now that arts is in use hmmm , would that solve this also?
terlmanngames-arcade/ppracer is at .5 in svn
that's the version with multiplayer
gOLdenHaWK3DI have a problem. I installed Gentoo on my system. Everything went fine till the Kernel download. When I was configuring Kernel using menuconfig, my brother mistakedly unplugged my pc! Now, how do i continue with my installation?
terlmannAnd I want the packager's head for not giving it to me ;-P
hkBstYippMN: no, I don't think so. But QA issues are for devs to solve, not users. Ignore it or file a bug.
Fenix|workterlmann, then you're going to have to find a .5 ebuild and use your portage overlay
YippMNhkBst, ok if i ignore it then i can't install kbilliards :)
hkBstYippMN: the QA issue shouldn't be preventing you from installing, unless maybe you use strictest?
Fenix|workterlmann, you can find an ebuild here for ppracer-0.5_alpha, but you'll have to do the rest with overlay and stuff http://gentoo.zugaina.org/gpo/games-arcade.html.en#ppracer
gOLdenHaWK3DI have a problem. I installed Gentoo on my system. Everything went fine till the Kernel download. When I was configuring Kernel using menuconfig, my brother mistakedly unplugged my pc! Now, how do i continue with my installation?
YippMNhkBst, well yeah it won't instal it because of the arts use not being in IUSE
hkBstgOLdenHaWK3D: mount your stuff like before and continue configuring your kernel
Kartagishi
hkBstYippMN: what is your FEATURES?
Fenix|workgOLdenHaWK3D, well, you boot from the livecd again and mount everything like you did when starting, once you're in the chroot environment skip all the steps until you get back to kernel configuration and go from there
gOLdenHaWK3DhkBst: thanx! :) And do i have to chroot also?
hkBstgOLdenHaWK3D: yep
gOLdenHaWK3DFenix|work: Ok!
hkBst: Ok!
Fenix|workgOLdenHaWK3D, Ok! :p

Page: 1 8 15 22 29 36 43 50 57 64 71 78 85 92 99 106 113 120 127 134 141 148 155 162 169 176 

IrcArchive

NY Lost Funds