#apache - Wed 9 May 2007 between 01:06 and 01:56

NY Lost Funds



preinheimer2.0.59
fajita2.0.59 is the latest release in the 2.0.x series. However, you should consider getting 2.2.4
preinheimerthanks fajita
noodlok, what was your configure line?
preinheimer"./configure" "--enable-so" "--with-ssl" "--enable-rewrite" "--enable module=ssl" "--enable-deflate"
noodli don't think that's enough. --with-ssl just builds in openssl, not necessarily mod_ssl, let alone as a dso. you should try httpd -l to see what's static, and review the docs (ask fajita about configure)
preinheimerokay, thank you
fajita: ssl?
fajitassl is *Secure Sockets Layer. Ask me about mod_ssl or ssl vhosts see also http://httpd.apache.org/docs/2.2/ssl/
noodlcould be totally wrong though, it's been a while since i built 2.0
preinheimerfajita: mod_ssl?
fajitamod_ssl is http://httpd.apache.org/docs-2.0/ssl/ or http://www.modssl.org/ (for 1.3) or http://httpd.apache.org/docs-2.0/mod/mod_ssl.html or http://cvs.apache.org/~mads/ac2004/MO18mod_ssl.pdf or see mod_gnutls for an alternative
noodli tend to use --enable-mods-shared="ssl cache etc" which i think works with 2.0
see: http://wiki.apache.org/httpd/Recipes/ConfigAllMods (for how to build everything upfront, leaving LoadModule options for later)
majikmanin apahce 1.3, its possible to specify a user:group in the vhost section. is that no longer possible in apache2.x?
preinheimershared modules are slower but you can swap them out without rebuilding right?
noodlright
majikmanpreinheimer, i've gotten errors before when trying to include a shared module thats already statically compiled in
noodland they're only barely slower, if at all
majikman: User in vhost from 1.3 became SuexecUserGroup in 2.0+, but don't ask me how to use it :)
majikmanlol, good enough. thanks noodl
suexecuser is a module isnt' it?
noodlno, suexec is the module (and binary), suexecusergroup is its directive. but, close enough :)
majikmanyea, something like that =P
preinheimernoodl: I've got SSL working now, thank you
SteveWrightNZgak, apache2 on ubuntu7 passes the php file to the browser rather than executing it - wot did I miss ?
php5
fajitaphp5 is less likely to work or at http://www.zend.com/php5/zend-engine2.php
SteveWrightNZNot found
fajitaNot found is a 404
SteveWrightNZoh itsa bot
http://home.fishyman.co.nz/test.php
DeathC...
dabaRWhy would loading the environment file break fastcgi? My dispatch file is at http://pastie.textmate.org/59960 If I comment out the require for the environment it works.
DeathCSteveWrightNZ: AddType application/x-httpd-php .php
fajitaAddType application/x-httpd-php .php is wrong, use AddHandler application/x-httpd-php .php instead
disgrntldso... I have to generate a CSR, do you think godaddy will catch me if I use a wildcard in the CN when we didnt pay for it? =)
SteveWrightNZDeathC: thanks
DeathC: I already have ;
/etc/apache2/mods-available/php5.conf: AddType application/x-httpd-php .php .phtml .php3

Page: 3 10 17 24 31 38 45 52 59 66 73 

IrcArchive

NY Lost Funds