#apache - Wed 28 Mar 2007 between 04:35 and 05:54

NY Lost Funds



elliottcableOk, I chown'd the htdocs dir to the deploy user
and it still says forbidden
and I have Indexes option on
[Tue Mar 27 23:32:45 2007] [error] [client 69.178.88.40] client denied by server configuration: /s/htdocs/dummy1.elliottcable.com/
pitilloelliottcable, put that error in google and you will find clues about. (You will need to review your server's config fle)
elliottcablepitillo: I did, but I'm not understanding this...?
Something about the allow order I think?
pitilloelliottcable, if it is not related to perms, is a bad configuration. Check the options under / dir. (like you said, to order options)
elliottcableOrder allow,deny
fajitaOrder allow,deny is The Allow directives are evaluated before the Deny directives. Access is denied by default. Any client which does not match an Allow directive?does match a Deny directive will be denied access to the server
elliottcableAllow from all
pitilloand read slowly the httpd.conf file. It is commented and will give you a lot of info
elliottcableYeah, I just finished doing that, and finally went to start my server, and http access from anywhere is 'forbidden'
pitilloelliottcable, use the fajita's pastebin to paste your config and I can take a look to it. (But I not very good, like you see with my problem.)
elliottcablepitillo: Doing so...
pitillo: http://pastie.caboo.se/50012
I really don't know what's going wrong... error logs aren't being helpful...
Does anybody have a REALLY bare bones apache configuration?
Roobarb-Workdoes the user Apache runs as have traverse permissions (+x) on all directories from the root to your documentRoot ?
pitilloelliottcable, well, Try to remove the order option from / dir. And think about loading all that modules stuff you are doing.
(really are all needed?)
elliottcableIt's just the default conf file, I don't know.
I wish the default was a barebones that worked, instead a tutorial-in-comments file the DOESN'T work as default it is set up...
Did that, got the same error.
emanuelezhello
fajitawhat's up, emanuelez.
Roobarb-Workelliottcable: the default configuration should work, but I'm prety sure "deploy" isn't a default
elliottcableRoobarb-Work: I set up a deploy user
Roobarb-Workelliottcable: does the "deploy" user Apache runs as have traverse permissions (+x) on all directories from the root to your documentRoot ?
elliottcableRoobarb-Work: Should have, yes
Roobarb-WorkShould != Does
elliottcableI think I sort of figured it out though. For some reason, it's ignoreing the default config, and applying the 'dummy1' config
And the path that the documentroot is for the dummy1 config isn't 'allow all'd by the conf thingie, i think.
lol or something like that, I'm bad at explaining. Let me fiddle, brb.
pitilloelliottcable, well, I think you may need to start a fresh config file... with the really needed. And add features bit by bit.
emanuelezi need to tweak my .htaccess with mod_rewrite to convert /grp-key/ to something.php?group=grp&keyword=key and /key/ to something.pgp?keyword=key but only if a directory called like key does not already exist! any hint?
elliottcablepitillo: WHich I'd rather do, but I can't find a barebones conf file ANYWHERE
pitilloelliottcable, think in the other way... I would start with modules... Make a backup of your conf and try to remove all modules what you dont need
elliottcablepitillo: I've figured out my problem, I can steamroll other weirdness from here. Thanks!
CuriosCatHi all.

Page: 5 12 19 26 33 40 47 

IrcArchive

NY Lost Funds